2.71 Dowgrader Graphic

Dark_Alex in conjunction with Mathieulh has released the first known 2.71 downgrader. The 2.71 downgrader is a port of the old 2.50/2.60 downgrader to use the recently discover libtiff exploit. The procedure is almost identical to that of the 2.50/2.60 downgrader except this time around you won’t need GTA. As always, be very cautious. Homebrew applications like this that write the PSP’s flash memory and can potentially turn your PSP into an expensive paper weight. If you do decide to go through with it, be sure to read PSP Updates’ spiel about it; you’ll also find the download links there.

Update: Dark_Alex and Mathieulh have released a bug fix for the 2.71 downgrader to fix premature bricking if the flash process failed.

[via PSP Updates]

12 Responses to “2.71 downgrader released! [updated]”

  1. 1 nnnnnaaaaaannnnnnnnnnnnnnnggggggggggggg

    OOOOOOOOOOOOOOOOIIIIIIIIIIIIIIIIIIIIIII i just BRicked My psp HATE U ALEX

  2. 2 gaaaaaaaaaaaaaaaaaaaaaaaaaaaa

    i just briked my psp!!!!!!!!!!!!!!!!!!!!!!

  3. 3 slikmeister@hotmail.com

    oi any1 does this reeli werk coz i dont wanna brik me psp

  4. 4 mrk

    I think the only thing those guys have bricked is their brain

  5. 5 webfeind2000

    yeah do you realize that the screen will blank on restart for a good minute or 2 while it reinitializes the psp. Same thing when you use Sony’s PSP updater ;)

  6. 6 webfeind2000

    You do realize that the screen will blank after restart for a few minutes while the PSP is reinitialized. Same with the Sony PSP updater. ;)

  7. 7 me

    ther’s a 2.82 downgrader at jufjufjuf.piczo.com they say they delete it soon hurry!!

  8. 8 hey

    ok i just helped my friend downgrade his psp but after it says press x to restart and i turned it back on, the screen is just black now.

  9. 9 lol...bricked

    u bricked ur friends psp… owned

  10. 10 ahahahahhaha

    thats one expensive fuck up! ahahahahahaha

  11. 11 I cannot take this anymore... Saying everything I said before. All these words they make no sense. I find bliss in ignorance.

    If you wish to download the Generic 2.71 DownFLASHER by Dark_Fooby, then read my name and name the song and singer/band of it.

    P.S. This DownFLASHER allows you to generically extract the 2.71 files(flash0) from your PSP and then the Generic 2.71 DownFLASHER will do a 2-minute long extraction from the DownFLASHER and will now safely replace your PSP’s flash0 to a 1.50N1-3 flash files. The N1 means it’s the first most powerful DownFLASHER for the firmware you’re overwriting and the -3 means it’s a patch, making it even more safer.

    So practically, it’s a flasher which can cause no bricking damage at ALL.

    Dark_Fooby said he will create a “Generic 3.50 DownFLASHER C2-1″
    The C2 means it normally requires a UMD but D_F extracted the files of the required UMD file into the DownFLASHER and requires no UMD at all for it.

    All DownFLASHERs can cause no damage at all.

    By the way, 3.50 is the highest DownFLASHER D_F can create because D_F needs an existing and working downgrader to create a working DownFLASHER. D_F might make a “JigKick SoloFLASHER” which means it may downgrade any PSP using one application – The rumored “JigKick SoloFLASHER” cannot unbrick – only downgrade.

  12. 12 heh

    I don’t get it!
    I want to downgrade my 2.71 but alot of people are saying it will brick it, even though I downgraded my friends one and it worked fine!
    WTF!?




Site Sponsors





Syndicate Me!

PGR has a number of RSS and Atom feeds so that you can quickly and easily keep up to date with the news posted here.


 


vgamin Advertise on the Blogads Gaming Network TechPodcasts